rose-pine-nix/modules/nixos/globals.nix
punkfairie f26b1be83f
Some checks are pending
CI / Format Nix files (push) Waiting to run
CI / Test Modules (push) Waiting to run
CI / Validate sources (push) Waiting to run
Release / Make release (push) Waiting to run
Release / Publish to Flake registries (push) Blocked by required conditions
Build & deploy website / Build site (push) Waiting to run
Build & deploy website / Deploy website (push) Blocked by required conditions
refactor(nixos): Use new helpers; formatting
2024-11-04 20:57:54 -08:00

36 lines
918 B
Nix

{ lib, ... }:
{
config = {
assertions = [ (lib.rp.assertMinimumVersion "24.05") ];
};
options.rose-pine = {
enable = lib.mkEnableOption "Rosé Pine globally";
flavor = lib.mkOption {
type = lib.rp.types.flavorOption;
default = "main";
description = "Global Rosé Pine flavor";
};
accent = lib.mkOption {
type = lib.rp.types.accentOption;
default = "love";
description = "Global Rosé Pine accent";
};
sources =
let
defaultSources = import ../../.sources;
in
lib.mkOption {
type = lib.types.lazyAttrsOf lib.types.raw;
default = defaultSources;
defaultText = "{ ... }";
# HACK!
# without this, overriding one source will delete all others. -@getchoo
apply = lib.recursiveUpdate defaultSources;
description = "Port sources used across all options";
};
};
}